Banner Right1.2 - Chi tiết tin - 300x250 - 222222

Với phiên bản Android Q, Google quyết tâm không để vụ việc Fortnite tái diễn

Khải sở khanh 05/09/2018 11:37
Tin tài trợ

Google hi vọng phiên bản Android tiếp theo sẽ chấm dứt trò bịp bợm mà các nhà phát triển như Epic Games đang cố thực hiện.

Theo đó, dù Google không thể buộc các OEM (Nhà sản xuất thiết bị gốc) cập nhật tất cả các điện thoại của họ lên phiên bản Android mới nhất, gã khổng lồ tìm kiếm ít nhất có thể “khuyến khích” các nhà phát triển ngừng cung cấp phần mềm cho các thiết bị đã quá lỗi thời. Dựa trên những gì chúng ta đã thấy trên Android 9 Pie và những thay đổi có thể xuất hiện trong phiên bản Android Q tiếp theo, có vẻ như Google sẽ đưa ra những cảnh báo đến người dùng về việc các ứng dụng họ đang sử dụng được thiết kế cho các phiên bản Android cũ, và hi vọng hành động “sỉ nhục” các nhà phát triển (rằng phần mềm của họ viết cho các hệ điều hành cũ, không phải mới) sẽ ngăn họ đi theo lối mòn mà Fortnite cho Android đã tạo ra.


Google đã bắt đầu triển khai một chính sách, trong đó khi các ứng dụng mới yêu cầu được phê duyệt để xuất trên Google Play Store, chúng sẽ bị buộc phải dành cho Android 8.0 Oreo trở về sau. Và bắt đầu từ tháng 11 này, các bản cập nhật dành cho các ứng dụng hiện có cũng phải làm điều tương tự. Tất nhiên, Google vẫn để các nhà phát triển tự do đặt cấp độ API tối thiểu theo ý muốn, tức là các ứng dụng vẫn sẽ có thể hoạt động trên các phiên bản Android cũ hơn.


Thông báo của Google: “Ứng dụng này được phát triển cho một phiên bản Android cũ và có thể không hoạt động tốt. Thử kiểm tra cập nhật hoặc liên hệ nhà phát triển”

Theo như diễn đàn XDA thì Google cũng đã triển khai một tính năng trong Android Pie nhằm cảnh báo người dùng rằng một ứng dụng được phát triển cho một phiên bản Android cũ. Trên Android Q, họ sẽ tiến thêm một bước nữa: đặt ra quy định phiên bản API tối thiểu từ 17 (Android 4.2 Jelly Bean) đến 23 (Android 6.0 Marshmallow). Có nghĩa là những popup cảnh báo như bạn thấy ở hình trên sẽ xuất hiện mỗi lần người dùng chạy một ứng dụng được viết cho Android 5.0 Lollipop hoặc cũ hơn.

Tất nhiên, các ứng dụng này vẫn sẽ chạy được như thường, và Google có lẽ đang…nói dối một chút: ứng dụng vẫn tiếp tục hoạt động như trước đây, nhưng hãng lại nói rằng không có gì đảm bảo cả. Điều Google thực sự muốn nói là những ứng dụng viết cho Lollipop trở về trước không sử dụng các tính năng bảo mật và quyền riêng tư mà hãng giới thiệu trên Marshmallow, đặc biệt là các quyền đòi hỏi trong quá trình chạy.


Những điều nói trên khá thú vị nếu bạn nhìn lại biến cố Fortnite cho Android vừa qua. Bên cạnh việc né tránh khoản lợi nhuận 30% phải chia cho Google, Epic Games còn nói không với Google Play Store bởi hãng này viết Fortnite cho Android 5.0 Lollipop, có nghĩa là chỉ cần người dùng nhấn OK trong quá trình cài đặt, Fortnite sẽ có toàn quyền làm biết kỳ điều gì nó thích trên thiết bị của họ – một hành vi xâm phạm bảo mật nghiêm trọng, và Google hi vọng phiên bản Android tiếp theo sẽ chấm dứt trò bịp bợm mà các nhà phát triển như Epic Games đang cố thực hiện.

Tham khảo: SlashGear, Helino

Viết bình luận